• 软件测试技术
  • 软件测试博客
  • 软件测试视频
  • 开源软件测试技术
  • 软件测试论坛
  • 软件测试沙龙
  • 软件测试资料下载
  • 软件测试杂志
  • 软件测试人才招聘
    暂时没有公告

字号: | 推荐给好友 上一篇 | 下一篇

ConfiguringIPInterVLANRoutingontheRSM

发布: 2007-6-20 23:14 | 作者:   | 来源:   | 查看: 15次 | 进入软件测试论坛讨论

领测软件测试网

   
  Step 1 (Optional) Enable IP routing on the router1.
  ip routing
  
  Step 2 (Optional) Specify an IP routing protocol2.
  router ip_routing_protocol
  
  Step 3 Specify a VLAN interface on the RSM.

  interface vlan-id
  
  Step 4 Assign an IP address to the VLAN.
  ip address n.n.n.n mask
  
  Step 5 Exit configuration mode.
  Ctrl-Z
  This example shows how to enable IP routing on the RSM, create a VLAN interface, and assign the interface an IP address:
  
  Router#configure terminal
  
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#ip routing
  
  Router(config)#router rip
  
  Router(config-router).network 10.0.0.0
  
  Router(config-router)#interface vlan 100
  
  Router(config-if)#ip address 10.1.1.1 255.0.0.0
  
  Router(config-if)#^Z
  
  Router#
  
  Configuring IP InterVLAN Routing on an External Ro
  Step 1 (Optional) Enable IP routing on the router1.
  ip routing
  
  Step 2 (Optional) Specify an IP routing protocol2.
  router ip_routing_protocol
  
  Step 3 Create a subinterface on a physical interface.
  interface interface_type interface_number.subinterface-_number
  
  Step 4 Specify the encapsulation and VLAN number to use on the subinterface.
  encapsulation encapsulation_type vlan_id
  
  Step 5 Assign an IP address to the subinterface.
  ip address n.n.n.n mask
  
  Step 6 Repeat Steps 3-5 for each VLAN between which you want to route traffic.
  
  
  Step 7 Exit configuration mode.
  Ctrl-Z
  
  This example shows how to enable IP routing on the router, create two subinterfaces, and specify the encapsulation, VLAN number, and IP address for each subinterface:
  
  Cisco7505#configure terminal
  
  Enter configuration commands, one per line. End with CNTL/Z.
  Cisco7505(config)#ip routing
  
  Cisco7505(config)#router rip
  
  Cisco7505(config-router)#network 10.0.0.0
  
  Cisco7505(config-router)#interface fastethernet2/0.100
  
  Cisco7505(config-subif)#encapsulation isl 100
  
  Cisco7505(config-subif)#ip address 10.10.1.1 255.255.0.0
  
  Cisco7505(config-router)#interface fastethernet2/0.200
  
  Cisco7505(config-subif)#encapsulation isl 200
  
  Cisco7505(config-subif)#ip address 10.20.1.1 255.255.0.0
  
  Cisco7505(config-subif)#^Z
  
  Cisco7505#
  
  InterVLAN Routing Configuration Examples
  [[The No.1 Picture.]]
   配置步骤
  1. Configure Switch A as a VTP server and assign a VTP domain name.
  
  2. Configure Switch B and Switch C as VTP clients and assign the same VTP domain name.
  
  3. Configure ISL trunk links between the switches.
  
  4. Create the VLANs on Switch A (the VLAN information is propagated to Switch B and Switch C through VTP).
  
  5. Assign the switch ports on each switch to the appropriate VLAN.
  
  6. On the RSM, create one VLAN interface for each VLAN configured on Switch A.
  
  7. Assign IP addresses to the VLAN interfaces.
  
  Switch A Configuration
  This example shows how to configure Switch A:
  
  SwitchA> (enable) set trunk 1/1 desirable
  
  Port(s) 1/1 trunk mode set to desirable.
  SwitchA> (enable) %DTP-5-TRUNKPORTON:Port 1/1 has become isl trunk
  %PAGP-5-PORTTOSTP:Port 1/1 joined bridge port 1/1
  %PAGP-5-PORTFROMSTP:Port 1/1 left bridge port 1/1
  %PAGP-5-PORTTOSTP:Port 1/1 joined bridge port 1/1
  
  SwitchA> (enable) set vtp domain Corporate
  
  VTP domain Corporate modified
  SwitchA> (enable) set vtp mode server
  
  VTP domain Corporate modified
  SwitchA> (enable) set vlan 2 name Engineering
  
  Vlan 2 configuration successful
  SwitchA> (enable) set vlan 3 name Marketing
  
  Vlan 3 configuration successful
  SwitchA> (enable) set vlan 4 name Accounting
  
  Vlan 4 configuration successful
  SwitchA> (enable) set vlan 2 3/1
  
  VLAN 2 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  2 3/1
  
  SwitchA> (enable) set vlan 3 3/2
  
  VLAN 3 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  3 3/2
  
  SwitchA> (enable) set vlan 4 3/3
  
  VLAN 4 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  4 3/3
  
  SwitchA> (enable)
  
  Switch B Configuration
  This example shows how to configure Switch B:
  
  SwitchB> (enable) set trunk 1/2 desirable
  
  Port(s) 1/2 trunk mode set to desirable.
  SwitchB> (enable) %DTP-5-TRUNKPORTON:Port 1/2 has become isl trunk
  %PAGP-5-PORTTOSTP:Port 1/2 joined bridge port 1/2
  %PAGP-5-PORTFROMSTP:Port 1/2 left bridge port 1/2
  %PAGP-5-PORTTOSTP:Port 1/2 joined bridge port 1/2
  
  SwitchB> (enable) set vtp domain Corporate
  
  VTP domain Corporate modified
  SwitchB> (enable) set vtp mode client
  
  VTP domain Corporate modified
  SwitchB> (enable) set vlan 2 3/1
  
  VLAN 2 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  2 3/1
  
  SwitchB> (enable) set vlan 3 3/2
  
  Vlan 3 configuration successful
  VLAN 3 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  3 3/2
  
  SwitchB> (enable) set vlan 4 3/3
  
  Vlan 4 configuration successful
  VLAN 4 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  4 3/3
  
  SwitchB> (enable)
  
  Switch C Configuration
  This example shows how to configure Switch C:
  
  SwitchB> (enable) set vtp domain Corporate
  
  VTP domain Corporate modified
  SwitchB> (enable) set vtp mode client
  
  VTP domain Corporate modified
  SwitchB> (enable) set vlan 2 3/1
  
  VLAN 2 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  2 3/1
  
  SwitchB> (enable) set vlan 3 3/2
  
  Vlan 3 configuration successful
  VLAN 3 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  3 3/2
  
  SwitchB> (enable) set vlan 4 3/3
  
  Vlan 4 configuration successful
  VLAN 4 modified.
  VLAN 1 modified.
  VLAN Mod/Ports
  ---- -----------------------
  4 3/3
  
  SwitchB> (enable)
  
  RSM Configuration
  This example shows how to configure the RSM:
  
  SwitchA> (enable) session 5
  
  Trying Router-5...
  Connected to Router-5.
  Escape character is '^]'.
  
  Router>enable
  
  Router#configure terminal
  
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#interface vlan 2
  
  Router(config-if)#
  %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to down
  Router(config-if)#ip address 172.20.52.33 255.255.255.224
  
  Router(config-if)#no shutdown
  
  %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up
  Router(config-if)#interface vlan 3
  
  Router(config-if)# <

文章来源于领测软件测试网 https://www.ltesting.net/


关于领测软件测试网 | 领测软件测试网合作伙伴 | 广告服务 | 投稿指南 | 联系我们 | 网站地图 | 友情链接
版权所有(C) 2003-2010 TestAge(领测软件测试网)|领测国际科技(北京)有限公司|软件测试工程师培训网 All Rights Reserved
北京市海淀区中关村南大街9号北京理工科技大厦1402室 京ICP备10010545号-5
技术支持和业务联系:info@testage.com.cn 电话:010-51297073

软件测试 | 领测国际ISTQBISTQB官网TMMiTMMi认证国际软件测试工程师认证领测软件测试网